internetbankieren

Mozilla Firefox is de webbrowser van Mozilla. Volg in geval van problemen eerst onze standaard diagnose.
viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

internetbankieren

Bericht door viko » 18 oktober 2016, 18:29

Hallo, ik heb het volgende probleem : bij internetbankieren moet ik steeds opnieuw mijn kaartnummer inbrengen, een vinkje zetten bij 'kaart bewaren' werkt niet, de volgende keer dat Firefox start is alles verdwenen.
Bij de opties staat aangevinkt : navigatie- en downloadgeschiedenis onthouden, Zoek- en formuliergeschiedenis onthouden, Cookies van websites accepteren, Geschiedenis wissen zodra Firefox sluit.
Wat doe ik verkeerd ?
Knipsel.JPG
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 18 oktober 2016, 18:57

De instellingen die je noemde lijken wel in orde te zijn, maar de schermafbeelding toont instellingen voor zaken die worden verwijderd bij het afsluiten van Firefox, waaronder cookies. Gebeurt het daarom ook als je Cookies in dit venster uitvinkt? Zo niet, zal elk bezoek aan de website als nieuw worden gezien. Het kaartnummer lijkt misschien een kwestie van invoergegevens (oftewel formuliergeschiedenis, die wel behouden blijft met deze instellingen), maar in combinatie met cookies ligt dat net iets anders.

Sommige gebruikers vinden het overigens wel fijn als dit soort gegevens niet bewaard blijven, ook al is het alleen een kaartnummer.

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 18 oktober 2016, 19:24

Ja, als ik de cookies uitvink is het net het zelfde. Het kaartnummer blijft staan zolang de browser open blijft, maar als ik hem afsluit en opnieuw start is het kaartnummer weer verdwenen. Ik vind het wel makkelijker om niet telkens dat nummer te moeten intikken, dit is alleen op deze computer thuis.

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 18 oktober 2016, 19:35

Het gedrag wordt denk ik mede bepaald door de eigenaar/maker van de website en kan dus een beveiligingsmaatregel zijn. Voor toegang tot mijn webmail bijvoorbeeld wordt de gebruikersnaam ook niet onthouden, ongeacht wat ik in Firefox instel. Als je dit zeker wilt weten, zou je het natuurlijk kunnen navragen bij de bank. Of wordt het nummer wel onthouden in een andere browser?

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 18 oktober 2016, 19:43

Ik heb het voor de zekerheid ook eens getest met Microsoft Edge en daar werkt het wel. Cookies uitgevinkt.
In de handleiding over homebanking staat dat het moet werken als je een vinkje zet bij 'nummer onthouden' .. :(

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 18 oktober 2016, 20:24

Gebruik je misschien een add-on die JavaScript blokkeert, zoals NoScript of uBlock/uMatrix? Ook zou je Firefox kunnen herstarten met uitgeschakelde add-ons (via het menu Help) om te controleren of hetzelfde gebeurt, of een nieuw profiel kunnen aanmaken om hetzelfde te testen, voor het geval er een andere instelling is gewijzigd die dit veroorzaakt.

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 18 oktober 2016, 21:11

Geen add-on. Nieuw profiel werkt ook niet.
Ik heb het op de laptop geprobeerd en het is hetzelfde liedje. Euvel ligt bij Firefox, ik geef het op.
Bedankt voor de hulp.

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 18 oktober 2016, 21:45

Graag gedaan, maar ik geef niet op, want alles is te fixen. :)

Kun je misschien de link voor het aanmelden geven?

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 19 oktober 2016, 8:31

Dat is dan heel lief van je !
Hier komt ie :
https://home.axabank.be/login?lang=nl&_ ... 1474981454
Alvast nog een keer bedankt !

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 19 oktober 2016, 13:39

Ik kan het mis hebben, maar het lijkt erop dat het bewaren van de veldwaarde in dit veld is uitgeschakeld door de volgende regel in de bron van de aangeboden pagina:

<input name="save" id="save" autocomplete="off" type="checkbox">

Dit kun je eventueel zelf zien als je de website bezoekt en de Inspector opent via menu Extra > Webontwikkelaar (of Ctrl-Shift-C), dan in het bewuste veld klikt, en iets eronder kijkt. Uitschakelen van deze modus kan via het kruisje rechts in het midden, of hetzelfde menu. Het deel 'autocomplete="off"' lijkt hier opzet en vaker door banken te worden gehanteerd.

Het zou natuurlijk kunnen dat de pagina browser-specifieke versies aanbiedt. Kun je een browser noemen waarbij het wel werkt, of wordt de waarde bij geen enkele browser onthouden?

Verder ben ik niet zo goed op de hoogte van HTML-taal, anderen op dit forum wellicht meer. Wel gaf iemand een tip over het gebruik van 'bookmarklets' (link naar supportartikel), wat zoiets zijn als JavaScript-opdrachten; zie daarvoor deze pagina. Als je daar op het groene 'remember password' klikt, of handiger: deze bookmarklet naar de bladwijzerwerkbalk sleept, kun je die 'bladwijzer' gebruiken om het gedeelte voor het uitschakelen in de bovengenoemde regel tijdelijk te negeren, wat dan denk ik maar 1 keer nodig is. Als je op de pagina wat naar beneden scrollt, zie je ook uitleg over deze bookmarklet. Ik kan zelf niet testen of het werkt, want waarschijnlijk wordt het daadwerkelijk bewaren uitgevoerd via een cookie, en pas na het invoeren van een juist rekeningnummer aldaar waarover ik niet beschik. :)

Laat maar even weten of het helpt, en uiteraard zou ik willen weten of het in andere browsers wel werkt zonder de bookmarklet. Als namelijk blijkt dat dat zo is, zou je de bank kunnen vragen dit voor Firefox te laten aanpassen. En als de bookmarklet in Firefox niet werkt, zou ik er goed naast kunnen zitten en er een andere oorzaak of wellicht gegronde reden kunnen zijn.

Verder vond ik ook dit artikel waarin een (wat oudere) andere oplossing wordt genoemd (het aanmaken van een bladwijzer die je rekeningnummer bevat), maar ik weet niet of dat nog werkt. Ook zag ik hier een soortgelijk probleem, en hier een artikel met wat meer achtergrondinformatie over de mogelijk genomen maatregel (let vooral op dit bericht). Tot slot kun je hier * en hier nog discussies vinden over de vraag of dit negeren wel zo handig is. Toevallig wordt op de pagina met de * vermeld dat de genoemde bookmarklet misschien ook niet meer werkt.

Al met al lijkt het er dus sterk op dat deze 'klacht'' voortkomt uit steeds vaker genomen beveiligingsmaatregelen, al zou je verwachten dat men dat vinkje dan ook zou weghalen. Een waarschuwing is echter wel op zijn plaats; over het algemeen is het niet verstandig om gebruikersgegevens op te slaan, ook het rekeningnummer niet. Onthoud ook dat cookies altijd onversleutelde tekst bevatten, en dat als je cookies verwijdert, je het nummer toch opnieuw moet invoeren. Mocht het daarom lukken om het invoeren van het nummer op welke manier dan ook te automatiseren, is dat voor eigen risico en ben je gewaarschuwd. ;)

Edit: zie ook deze supportvraag en het daarin genoemde KB-artikel op mozillaZine, waarin ook over (aangepaste) bookmarklets wordt gesproken.

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 20 oktober 2016, 16:56

Ja, in Microsoft Edge werkt het perfect :
2.JPG
Knipsel.JPG
(Ondertussen heb ik Edge al opgeruimd, 'kaart niet langer onthouden' en cookies gewist.)

Hoh Torzan, je hebt er wel je werk van gemaakt ! Een hele boterham uitleg, waarvoor dank. Na het lezen van dit alles lijkt het mij toch beter om telkens het nummer eigenhandig in te tikken. Misschien heb ik wel een extra veilige bank EN dito browser. :D
De bookmarklet heb ik in Firefox niet getest. Ondertussen had ik wel al de bank aangeschreven om het euvel te melden, maar tot nog toe geen antwoord ontvangen.
Als het nummer om beveiligingsmaatregelen niet meer onthouden wordt, kan ik dus alleen maar begrijpen dat Microsoft Edge niet zo veilig is .. :o
Maar geen nood, die gebruik ik toch niet .. alleen even getest.

Het artikel over Dexia (met een Mac) had ik al gelezen.
Merci :P
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 23 oktober 2016, 9:24

Dag Torzan,
Problem solved !!
Deze simpele oplossing kreeg ik van de bank : vergelijk de eerste printscreen met deze : er mag geen vinkje staan bij 'geschiedenis wissen als firefox afsluit.' Logisch wel, maar over het hoofd gezien.
Ik heb ook cookies bewaren gewijzigd in 'tot ze verlopen.' Denk niet dat dit kwaad kan doen ..
Fijne zondag nog.
Knipsel.JPG
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

Torzan
Berichten: 800
Lid geworden op: 16 januari 2016, 13:08
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0

Re: internetbankieren

Bericht door Torzan » 23 oktober 2016, 11:26

Hallo viko,

Wel wel... Dat het verwijderen van cookies bij afsluiten in het bovenste screenshot stond aangevinkt, was mij ook niet opgevallen, maar je zou toch zeggen dat het aanvinken van 'Geschiedenis wissen zodra Firefox sluit' en het uitvinken (en dus niet laten verwijderen) van 'Cookies' in het venster Uitzonderingen dat zou voorkomen. Je zou natuurlijk nog één voor één alle (7) items in dat venster kunnen aanvinken om te zien wanneer precies het niet meer werkt, waaruit dan blijkt dat een van de andere zaken daarin belangrijk zijn. Het is dat, óf de optie 'ik Firefox afsluit' in de instelling 'Bewaren totdat:' (die voor alle cookies moet gelden en niet alleen voor die van derden) heeft simpelweg voorrang boven de uitzonderingsinstellingen. In dat opzicht is het wel belangrijk of je 'tot ze verlopen' hebt geselecteerd of niet. Een kwestie van uitproberen; als het hierna al niet meer werkt, heeft deze instelling inderdaad voorrang.

Bedankt voor je terugkoppeling, en blijf voorzichtig handelen! En ook een fijne zondag. ;)

viko
Berichten: 86
Lid geworden op: 27 november 2006, 20:10
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Re: internetbankieren

Bericht door viko » 23 oktober 2016, 12:41

Ik heb nog een en ander getest : 'bewaren tot ik firefox' afsluit kan ook, dus dat heb ik terug aangezet.
Die 7 bij 'geschiedenis wissen' had ik al allemaal getest en ook zonder vinkjes werkte het niét, dus alleen met vinkje uit bij het laatste : 'geschiedenis wissen zodra firefox sluit' onthoudt de browser mijn nummer.
Ik zal voorzichtig handelen! :wink:
We hebben weer bijgeleerd ..