Audiolinks openen in Firefox

Mozilla Firefox is de webbrowser van Mozilla. Volg in geval van problemen eerst onze standaard diagnose.
Wilma
    unknown unknown

Audiolinks openen in Firefox

Bericht door Wilma »

Als ik in Mozilla Firefox op een link klik die een bestand in RealPlayer of MediaPlayer 9 zou moeten openen dan gebeurt er niks. Hooguit brengt de site me naar Apple Quicktime maar ik weet niet goed of ik die zou moeten downloaden aangezien ik 1. geen Apple heb en 2. al 2 players op mijn computer heb staan.

Hoe kan ik audiolinks afspelen in Firefox?

Groeten,
Wilma
Gebruikersavatar
ByteWarrior
Berichten: 3825
Lid geworden op: 15 oktober 2003, 14:56
Locatie: Tielt-Winge, België
    unknown unknown

Bericht door ByteWarrior »

Wat voor een bestand is het? Als het een Quicktime-bestand (.qt) is, moet je sowieso Quicktime downloaden. De andere speler kunnen dit helaas niet afspelen (zelfde met .rm en .wmv trouwens).

Dat is het probleem met muziek (en andere)bestanden. Elke fabrikant vindt een eigen formaat uit. Als je zeker wilt zijn dat je alles kunt beluisteren/bekijken, dan moet je Windows Media Player, RealPlayer en Quicktime hebben... (dat is nu net de reden waarom sommige mensen opteren voor open standaarden).

Als je de link van de website in kwestie geeft, kunnen we je misschien verderhelpen.
Gebruikersavatar
nirwana
Beheerder
Berichten: 11517
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

Ook zie ik onder http://www.squarefree.com/burningedge/b ... cture.html staan dat de ondersteuning van Windows Mediaspeler in Firefox sinds de 0.8-versie is uitgebracht verder is verbeterd:
"Make newer versions of the Windows Media Player control work in Firefox [Installer]"

De nieuwe versie van het Installatieprogramma van Firefox zou dus iets in het Windows Register moeten aanbrengen wat die ondersteuning verbeterd (ofzoiets).

Maar inderdaad is het altijd handig om adressen van sites waarmee je problemen hebt gewoon hier te vermelden. Dan kan iedereen zelf aanschouwen waardoor mogelijk problemen ontstaan en hoe deze eventueel zijn op te lossen.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Wilma
    unknown unknown

Bericht door Wilma »

Dat zijn er verschillende, audio en ook video:

Deze: http://www.nu.nl/news.jsp?n=301147&c=22
en deze: http://www.cbsite.nl/livestreaming.html

Waarom ik naar Quicktime werd gevoerd dat weet ik niet want dat doet hij nu niet meer. Misschien reclame.
Gebruikersavatar
nirwana
Beheerder
Berichten: 11517
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

Bij Nu.nl kan ik de video gewoon bekijken. Geen enkel probleem. Zie www.mozbrowser.nl/downloads/ftv.png

Bij CBSite is het een ander geval. Daar heeft men de plugin op z'n Microsofts in de pagina ingevoegd:
<!--webbot bot="HTMLMarkup" startspan -->
<object id="scannerstream" style="color: #ff0000; border-style: solid; border-width: 0" classid="clsid:CFCDAA03-8BE4-11CF-B84B-0020AFBBCCFA" align="top" width="150" height="54" border="0">
<param name="_ExtentX" value="7303">
<param name="_ExtentY" value="1429">
<param name="AUTOSTART" value="1">
<param name="SHUFFLE" value="0">
<param name="PREFETCH" value="0">
<param name="NOLABELS" value="0">
<param name="WINDOWNAME" value="scannerstream">
<param name="SRC" value="http://www.livescanner.nl/listen.pls" ref>
<param name="CONTROLS" value="controlpanel,StatusBar">
<param name="CONSOLE" value="Clip4">
<param name="LOOP" value="0">
<param name="NUMLOOP" value="0">
<param name="CENTER" value="0">
<param name="MAINTAINASPECT" value="0">
<param name="BACKGROUNDCOLOR" value="#000000"><embed align="baseline" border="0" width="275" height="140" type="audio/x-mpeg" console="Clip1" controls="ControlPanel,StatusBar" autostart="false"></object>
Dergelijke Webbot-tags duiden al op Microsoft Frontpage en dat belooft doorgaans weinig goeds.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Wilma
    unknown unknown

Bericht door Wilma »

Ik kan helaas geen enkele audio- en videolink openen, hoewel hij onder tools > filetypes zo wel staat ingesteld.
Overigens: zou het niet mogelijk (en wenselijk) zijn dat Mozilla Firefox ook overweg kan met kwalitatief minder goede codes?
Gebruikersavatar
ByteWarrior
Berichten: 3825
Lid geworden op: 15 oktober 2003, 14:56
Locatie: Tielt-Winge, België
    unknown unknown

Bericht door ByteWarrior »

Wilma schreef:Overigens: zou het niet mogelijk (en wenselijk) zijn dat Mozilla Firefox ook overweg kan met kwalitatief minder goede codes?
Volgens mij hangt dat niet echt van Firefox af. Eerder externe dingen zoals: de maker van de plugin (Macromedia, Apple, RealSoftware, ...) en de websitebouwer (want deze kiest uiteindelijk voor één formaat).

Op de meeste websites wordt geluid aangeboden in verschillende formaten (meestal 2 of meer). Op deze manier vermijd de websitebouwer dat de bezoeker niet naar het geluid kan luisteren...

Maar ik moet toegeven: er kan nog veel verbeterd worden op dit vlak.
Fergy
Berichten: 41
Lid geworden op: 24 maart 2004, 21:19
    unknown unknown

Bericht door Fergy »

Wat bij mij heel erg helpt is dit gebruiken: http://www.k-litecodecpack.com/

Het zorgt ervoor dat Media Player Classic Quicktime, Real, Windows Media enz. allemaal kan afspelen.[/url]
Wilma
    unknown unknown

Media Player Classic

Bericht door Wilma »

Sorry voor mijn late reactie. Ik ben Fergy's reactie misgelopen en ontdekte hem net pas.

Fergy, bedankt voor de tip. Ik heb daarnet Media Player Classic geprobeerd en hij werkt prima. Bij Windows Media Player kreeg ik telkens het bericht dat het om een verkeerd type of corrupt bestand ging wat hij niet kon afspelen.
Het had dus niks met Firefox te maken.
Ook RealPlayer werkt nu gewoon, waarschijnlijk gewoon pech gehad dat de server te druk was of iets anders toevalligs.
En op de Nu-site krijg ik nu ook de video te zien, als ik eerst maar op OK klik in het downloadvenstertje :idea:
Dus alles is nu opgelost. Bedankt nogmaals :)

Groeten,
Wilma
Babbe
    unknown unknown

Windows Mediaplayer

Bericht door Babbe »

Wilma schreef:Bij Windows Media Player kreeg ik telkens het bericht dat het om een verkeerd type of corrupt bestand ging wat hij niet kon afspelen.
Dit probleem ken ik; roep even Windows Media Player op, kijk onder Extra - Opties - Bestandstypen en dan ontbreekt in de lijst ergens een vinkje.

Als het bestandstype is gekoppeld aan Windows Mediaplayer in Mapopties, wil dat nog niet zeggen dat WMP die taak ook zomaar gaat uitvoeren :twisted:. Daarvoor heeft hij ook een vink nodig in WMP zelf, anders begint hij rare foutmeldingen uit te braken.