Ubuntu

Iedereen kan hier terecht met vragen over allerhande open source software die niet in de andere fora past.
rebil
Berichten: 507
Lid geworden op: 25 april 2006, 20:07
    unknown unknown

Bericht door rebil » 14 juni 2007, 20:27

D'oh, ik had over het hoofd gezien dat de website van die Pixma-driver waarnaar ik eerder linkte ook een Ubuntu-howto heeft. Je moet dan wel overal 0.12.0 vervangen door 0.13.0 en voor die SYSFS-dingen je eigen uitvoer van scan -L invullen.

Ik heb de driver zelf eens gecompileerd (de make-stap) en ik kreeg geen van de fouten en waarschuwingen die jij had. Als je met bovenstaande leidraad fouten krijgt dan is er iets niet pluis. Best eens hier laten zien dan.

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 15 juni 2007, 10:44

Rebil,

Ik dacht even een moment een prachtige vaderdag te gaan beleven, want ik kon ondertussen de terminal vinden, had her en der iets opgepikt, maar daar houd het op.

Ik heb de gegevens op de site (door jouw aangegeven) gekopieerd en daarna de 0.12.0 op diverse plekken veranderd in 0.13.0
De SYSFS dingen :wink: dat was een vraagstuk, ik heb daar tussen de aanhalings tekens neergezet {scan -L} weet niet of dat juist is.

Op een paar manieren heb ik toen geprobeerd de stappen in te voeren, eerst per groepje, later regel voor regel.
Maar er staat ook nog aan het eind van stap 2 " Add a line at the end and save" dat was me niet duidelijk, is dit een extra enter of met de spatiebalk een regel doortikken en dan een enter.

Ook het verhaaltje aan het eind van stap 3 snapte ik niet helemaal
# Pixma MP150
SYSFS{idVendor}=="04a9" enz. ik had het idee dat dit ergens tussen moest maar het is mij dus niet duidelijk.

Op het gevaar af dat de beheerder mij eruit knikkert na zoveel vragen en schrijfruimte hierbij een aantal afdrukken van wat er te zien was in de terminal.

bjstijf@bjstijf-desktop:~$ sudo apt-get install build-essential
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
Reading state information... Klaar
build-essential is reeds de nieuwste versie.
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
libopenexr2c2a libartsc0 libmono-security1.0-cil groff
libmono-sharpzip0.84-cil libmono-system-web1.0-cil kdelibs-data liblualib50
libpcre3 mgetty-fax libgnomescanui-common expect courier-base libmono1.0-cil
libmono-data-tds1.0-cil libmono-system-data1.0-cil courier-authlib-userdb
courier-authlib tcl8.4 libgnomescan-common libevolution-cil libgpgme11
liblua50 mgetty courier-authdaemon libltdl3
Gebruik 'apt-get autoremove' om deze te verwijderen.
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 0 niet opgewaardeerd.
bjstijf@bjstijf-desktop:~$ # wget http://home.arcor.de/wittawat/pixma/mp1 ... .2.tar.bz2
bjstijf@bjstijf-desktop:~$ # sudo tar xjf mp150-0.13.2.tar.bz2 -C /usr/src
bjstijf@bjstijf-desktop:~$ # cd /usr/src/mp150-0.13.2/
bjstijf@bjstijf-desktop:~$ # sudo make
bjstijf@bjstijf-desktop:~$ # sudo ./scan -L
bjstijf@bjstijf-desktop:~$ # sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.0.13.2
bjstijf@bjstijf-desktop:~$ # sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.2 /usr/lib/sane/libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$ # gksudo gedit /etc/sane.d/dll.conf bjstijf@bjstijf-desktop:~$ # gksudo gedit /etc/udev/rules.d/45-libsane.rules
bjstijf@bjstijf-desktop:~$ # Pixma MP150
bjstijf@bjstijf-desktop:~$ SYSFS{scan -L}==”04a9”, SYSFS{scan -L}==”1709”, MODE=”664”, GROUP=”scanner”
bash: SYSFS{scan: opdracht niet gevonden
bjstijf@bjstijf-desktop:~$ # sudo /etc/init.d/udev restart
bjstijf@bjstijf-desktop:~$


bjstijf@bjstijf-desktop:~$ # sudo apt-get install build-essential
bjstijf@bjstijf-desktop:~$ # wget http://home.arcor.de/wittawat/pixma/mp1 ... .2.tar.bz2
bjstijf@bjstijf-desktop:~$ # sudo tar xjf mp150-0.13.2.tar.bz2 -C /usr/src
bjstijf@bjstijf-desktop:~$ # cd /usr/src/mp150-0.13.2/
bjstijf@bjstijf-desktop:~$ # sudo make
bjstijf@bjstijf-desktop:~$ # sudo ./scan -L
bjstijf@bjstijf-desktop:~$ # sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.0.13.2
bjstijf@bjstijf-desktop:~$ # sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.2 /usr/lib/sane/libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$ # gksudo gedit /etc/sane.d/dll.conf bjstijf@bjstijf-desktop:~$ # gksudo gedit /etc/udev/rules.d/45-libsane.rules
bjstijf@bjstijf-desktop:~$ # Pixma MP150 SYSFS{scan -L}=="04a9", SYSFS{scan -L}=="1709", MODE="664", GROUP="scanner"
bjstijf@bjstijf-desktop:~$ # sudo /etc/init.d/udev restart

Ik zit ergens fout, (zonder twijfel) maar misschien als je even tijd hebt ? ook las ik "build-essential is reeds de nieuwste versie." staat die driver dan toch al ergens?

Je ziet het ik geef het nog niet op, maar er zullen er zijn die hun buik vol krijgen van mijn vragen en geklungel sorry

Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
adri
Moderator
Berichten: 11549
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri » 15 juni 2007, 12:45

Het lijkt erop dat je teveel commando's in eens wilt doen.
Die build-essentials heb je al dus dat kun je overslaan en de driver heb je al (ik ga er wel van uit dat die tarball nog steeds op je bureaublad staat!), dus die stappen slaan we over.
Stap voor stap kopieer je nu de volgende regels in je terminal (gevolgd door Enter):

sudo tar xjf /home/bjstijf/Desktop/mp150-0.13.0.tar.bz2 -C /usr/src

cd /usr/src/mp150-0.13.0/

sudo make

sudo ./scan -L
(je krijgt dan -als het goed is- zoiets als:
1: Canon PIXMA MP150 (SN:04A91709_123456)

sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.0.13.0

sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.0 /usr/lib/sane/libsane-pixma.so.1


gksudo gedit /etc/sane.d/dll.conf
Nu opent Gedit en onderaan in dat bestand plaats je de volgende regel:
pixma

Bestand opslaan en afsluiten

gksudo gedit /etc/udev/rules.d/45-libsane.rules
Nu opent Gedit weer en vóór de regel
LABEL="libsane_rules_end"
plaats je deze regels
# Pixma MP150
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="1709", MODE="664", GROUP="scanner"


Let op: {idVendor} en {idProduct} moet je zelf even aanpassen aan de hand van de output van sudo ./scan -L (zie 1)

bestand opslaan en afsluiten

sudo /etc/init.d/udev restart

En dan zou het goed moeten zijn en moet je kunnen scannen.

Succes.
Afbeelding

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 15 juni 2007, 16:28

Adri,

Heb jouw raad opgevolgd, en het volgende krijg ik tevoorschijn.

Het terminal scherm:

bjstijf@bjstijf-desktop:~$ sudo tar xjf /home/bjstijf/Desktop/mp150-0.13.0.tar.bz2 -C /usr/src

bjstijf@bjstijf-desktop:~$ cd /usr/src/mp150-0.13.0/

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo make

make: Er hoeft niets gedaan te worden voor 'all'.

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo ./scan -L

Connected scanner(s):

1: Canon PIXMA MP530 (SN:04A91712_124FBE)

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.0.13.0

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.0 /usr/lib/sane/libsane-pixma.so.1

ln: bezig symbolische koppeling `/usr/lib/sane/libsane-pixma.so.1' naar `/usr/lib/sane/libsane-pixma.so.0.13.0' aan te maken: Bestand bestaat al

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ gksudo gedit /etc/sane.d/dll.conf

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ gksudo gedit /etc/udev/rules.d/45-libsane.rules

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo /etc/init.d/udev restart

* Loading additional hardware drivers... [ OK ]

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$


En dit geeft het Gedit scherm:

GROUP="scanner"

# Dell A920

SYSFS{idVendor}=="413c", SYSFS{idProduct}=="5105", MODE="664", GROUP="scanner"

# Dell A960

SYSFS{idVendor}=="413c", SYSFS{idProduct}=="5107", MODE="664", GROUP="scanner"

# Dell 922

SYSFS{idVendor}=="413c", SYSFS{idProduct}=="5109", MODE="664", GROUP="scanner"

# Dell 1600n

SYSFS{idVendor}=="413c", SYSFS{idProduct}=="5250", MODE="664", GROUP="scanner"

# Pixma MP150

SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="1712", MODE="664",
GROUP="scanner"
LABEL="libsane_rules_end"



1: Canon PIXMA MP530 (SN:04A91712_124FBE)
Hiervan heb ik ingevuld,

04A9 en 1712 dit werkte niet terwijl de terminal (OKE) aangaf.
Daarna heb ik het geprobeerd met

04A9 en 1712_124FBE dit werkte ook niet, ook nu gaf de terminal ook (OKE) aan zie afdruk terminal.


Het is me niet helemaal duidelijk waar precies die _124FBE moet staan.

Daar zal ik nog iets mee moeten doen misschien, sane geeft aan geen scanner gevonden.

Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 15 juni 2007, 18:28

* Loading additional hardware drivers... [ OK ]

bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$



Dit is het laatste wat de terminal te zien geeft, moet ik dat nog verder afsluiten met een bepaald commando, of kan ik gewoon afsluiten met het Kruisje.

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
adri
Moderator
Berichten: 11549
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri » 15 juni 2007, 22:29

the old man schreef:SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="1712", MODE="664"
Dat zou in orde moeten zijn.
the old man schreef:Het is me niet helemaal duidelijk waar precies die _124FBE moet staan
Dat is een serienummer, daar wordt verder niets over gezegd, dus ik neem aan dat je het niet nodig hebt.
the old man schreef:Dit is het laatste wat de terminal te zien geeft, moet ik dat nog verder afsluiten met een bepaald commando, of kan ik gewoon afsluiten met het Kruisje.
Een terminal sluit je af met exit.
Maar op het kruisje klikken kan ook. ;)
the old man schreef:make: Er hoeft niets gedaan te worden voor 'all'.
Dit zit me niet helemaal lekker. Ik ben echter bepaald geen expert op het gebied van drivers installeren, maar het lijkt me dat je na make een hele waslijst aan data voorbij hoort te zien komen.

Concreet, de scanner wordt wel herkend, maar de driver functioneert -nog- niet. Punt waar ik eerder al over prakkiseerde: die howto geldt voor Dapper Drake, jij hebt Feisty Fawn (toch?), die heeft weer een andere kernel en waarschijnlijk nog veel meer zaken anders dan Dapper Drake.
Ik vrees dus dat ik je hier niet verder mee helpen kan. Misschien dat rebil of iemand anders nog een gouden idee heeft, maar ik zit er wel een beetje doorheen... :(

Tip voor de toekomst: als je hardware koopt, beding dan dat je het binnen een week onder Linux aan de praat krijgt, zo niet, dan retour.

Overigens vind ik het bewonderenswaardig hoe vasthoudend je bent. Linux is echt wel iets voor jou. ;)
Afbeelding

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 16 juni 2007, 10:01

Je snapt natuurlijk wel dat ik geen steek verder gekomen was zonder jullie hulp.
De MP530 print nu in ieder geval en dat scannen zal nog komen daar ben ik van overtuigd.
Het zal best frustrerend zijn al die vragen die voor jullie gesneden koek zijn.
Maar het is ook duidelijk dat een beginneling geen stap verder komt zonder dit soort hulp.

Waarvoor mijn dank en waardering, ennnnn jullie zijn echt nog niet van me af, er zal zich nog wel vaker iets voordoen waarvoor ik hulp in zal roepen.

Maar wie weet heeft Rebil of een ander kopstuk :D :idea: nog iets of vindt iemand dat nog uit, dan hou ik me aanbevolen.

Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie » 16 juni 2007, 14:07

Je kunt het volgende eens proberen in je terminal en kijken of de scanner dan wel door sane herkend wordt. :wink:
Hieronder wordt een verwijzing gemaakt.

1
sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.1.0.13

2
sudo mv /usr/lib/sane/libsane-pixma.so.1 /usr/lib/sane/libsane-pixma.so.2

3
sudo ln -s /usr/lib/sane/libsane-pixma.so.1.0.13 /usr/lib/sane/libsane-pixma.so.1

En dan.
sudo /etc/init.d/udev restart
Afbeelding

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 16 juni 2007, 14:20

Goede middag Rappie P.

Dit is de uitkomst van jouw voorstel.

bjstijf@bjstijf-desktop:~$ sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.1.0.13
Password:
cp: kan de rechten van `libsane-pixma.so' niet veranderen: Bestand of map bestaat niet
bjstijf@bjstijf-desktop:~$ sudo mv /usr/lib/sane/libsane-pixma.so.1 /usr/lib/sane/libsane-pixma.so.2
bjstijf@bjstijf-desktop:~$ sudo ln -s /usr/lib/sane/libsane-pixma.so.1.0.13 /usr/lib/sane/libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$
bjstijf@bjstijf-desktop:~$ sudo /etc/init.d/udev restart
* Loading additional hardware drivers... [ OK ]
bjstijf@bjstijf-desktop:~$


Misschien moet ik erbij vermelden dat Sane wel mijn oude scanner Canoscan D660U herkent.
Maar daar heb ik niets aan die is stuk qua transport van de lamp enz.

Groet,

de Ouwe
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie » 16 juni 2007, 15:33

Hmmm! :? Lijkt erop of hij een bestand niet aangemaakt heeft of dat je er géén rechten over hebt om het te veranderen.

sudo chown "gebruikersnaam" /usr/lib/sane/libsane-pixma.so.1.0.13

En daarna in je terminal weer de regels die ik je al eerder gegeven heb.
Afbeelding

Gebruikersavatar
rappie pappie
Berichten: 1503
Lid geworden op: 19 januari 2006, 14:01
    unknown unknown

Bericht door rappie pappie » 16 juni 2007, 15:43

Als bovenstaande nog niet lukt post de uitslag eens van.

sudo gedit /etc/sane.d/dll.conf
Afbeelding

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 16 juni 2007, 16:01

Rappie P.

Het lukte niet, hieronder wel de uitslag van jouw laatste advies.

# /etc/sane.d/dll.conf - Configuration file for the SANE dynamic backend loader
#
# On Debian systems, the dll backend will also look for pieces of configuration
# in the /etc/sane.d/dll.d directory -- packages providing backends should drop
# a config file similar to dll.conf in this directory.
#

# enable the next line if you want to allow access through the network:
net
abaton
agfafocus
apple
avision
artec
artec_eplus48u
as6e
bh
canon
canon630u
#canon_pp
coolscan
coolscan2
#dc25
#dc210
#dc240
dell1600n_net
dmc
epson
fujitsu
#gphoto2
genesys
gt68xx
hp
hpsj5s
hp3500
hp4200
hp5400
ibm
leo
lexmark
ma1509
matsushita
microtek
microtek2
mustek
#mustek_pp
mustek_usb
mustek_usb2
nec
niash
pie
pixma
plustek
#plustek_pp
#pnm
qcam
ricoh
s9036
sceptre
sharp
sm3600
sm3840
snapscan
sp15c
#st400
#stv680
tamarack
teco1
teco2
teco3
#test
u12
umax
#umax_pp
umax1220u
v4l
pixma
pixma



Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

rebil
Berichten: 507
Lid geworden op: 25 april 2006, 20:07
    unknown unknown

Bericht door rebil » 16 juni 2007, 19:38

Tijdens het uitvoeren van adri's commando's ging het hier fout:
bjstijf@bjstijf-desktop:/usr/src/mp150-0.13.0$ sudo ln -s /usr/lib/sane/libsane-pixma.so.0.13.0 /usr/lib/sane/libsane-pixma.so.1

ln: bezig symbolische koppeling `/usr/lib/sane/libsane-pixma.so.1' naar `/usr/lib/sane/libsane-pixma.so.0.13.0' aan te maken: Bestand bestaat al
Dat komt omdat in Ubuntu al een Pixma-driver zit, nl. versie 0.11.3, maar jouw scanner werd daardoor nog niet ondersteund.

Laten we eens kijken welke Pixma-driverbestanden je allemaal hebt:
cd /usr/lib/sane

ls libsane-pixma.so*

De uitkomst daarvan is nu waarschijnlijk:

libsane-pixma.so.0.13.0
libsane-pixma.so.1
libsane-pixma.so.1.0.18
libsane-pixma.so.2


Die libsane.pixma.so.1 is volgens mij waar SANE naar gaat zoeken. Als we nu eens kijken waar dat naartoe wijst (het is een link):

ls -l libsane-pixma.so.1

Dan zie je waarschijnlijk dat het naar libsane-pixma.so.1.0.13 wijst, maar dat bestand bestaat helemaal niet. Het idee van rappie pappie was wel goed, maar hij is er iets te vlug overgegaan (verkeerd versienummer). De link moet eigenlijk naar libsane-pixma.so.0.13.0 wijzen. Daarom gaan we eerst de link verwijderen:

rm libsane-pixma.so.1

Om hem dan naar het juiste bestand te laten wijzen:

ln -s libsane-pixma.so.0.13.0 libsane-pixma.so.1

Als je het systeem dan nog eens naar apparaten laat zoeken:

sudo /etc/init.d/udev restart

dan zou het apparaat herkend moeten worden als je het scanprogramma start.

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 16 juni 2007, 19:44

Rebil,

Heb net m'n beste kloffie aan om naar een feestje te gaan, morgen ga ik e.e.a. uitproberen en je zult ongetwijfeld horen.

tot zover bedankt.

Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll:

Gebruikersavatar
the old man
Berichten: 318
Lid geworden op: 2 maart 2005, 19:11
    unknown unknown

Bericht door the old man » 17 juni 2007, 8:24

Goede morgen Rebil en alle anderen.

Dit is het resultaat van jouw voorstel.

Rebil,

Als ik jouw commando's achter elkaar in de terminal uitvoer, is dit het resultaat.

bjstijf@bjstijf-desktop:~$ cd /usr/lib/sane

bjstijf@bjstijf-desktop:/usr/lib/sane$ ls libsane-pixma.so*

libsane-pixma.so.0.13.0 libsane-pixma.so.1.0.18

libsane-pixma.so.1 libsane-pixma.so.2

bjstijf@bjstijf-desktop:/usr/lib/sane$ ls -l libsane-pixma.so.1

lrwxrwxrwx 1 root root 37 2007-06-16 16:58 libsane-pixma.so.1 -> /usr/lib/sane/libsane-pixma.so.1.0.13

bjstijf@bjstijf-desktop:/usr/lib/sane$ rm libsane-pixma.so.1

rm: kan `libsane-pixma.so.1' niet verwijderen: Toegang geweigerd

bjstijf@bjstijf-desktop:/usr/lib/sane$ ln -s libsane-pixma.so.0.13.0 libsane-pixma.so.1

ln: bezig symbolische koppeling `libsane-pixma.so.1' naar `libsane-pixma.so.0.13.0' aan te maken: Bestand bestaat al

bjstijf@bjstijf-desktop:/usr/lib/sane$ sudo /etc/init.d/udev restart

* Loading additional hardware drivers... [ OK ]

bjstijf@bjstijf-desktop:/usr/lib/sane$

Als ik de commando's uitvoer, (stuk voor stuk in blanco terminal) is dit het resultaat.

cd /usr/lib/sane

ls libsane-pixma.so*

bjstijf@bjstijf-desktop:~$ cd /usr/lib/sane

bjstijf@bjstijf-desktop:/usr/lib/sane$ ls libsane-pixma.so*

libsane-pixma.so.0.13.0 libsane-pixma.so.1.0.18

libsane-pixma.so.1 libsane-pixma.so.2

bjstijf@bjstijf-desktop:/usr/lib/sane$


ls -l libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$ ls -l libsane-pixma.so.1

lrwxrwxrwx 1 bjstijf bjstijf 23 2007-06-17 08:47 libsane-pixma.so.1 -> libsane-pixma.so.0.13.0

bjstijf@bjstijf-desktop:~$


rm libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$ rm libsane-pixma.so.1

bjstijf@bjstijf-desktop:~$

ln -s libsane-pixma.so.0.13.0 libsane-pixma.so.1
bjstijf@bjstijf-desktop:~$ ln -s libsane-pixma.so.0.13.0 libsane-pixma.so.1

bjstijf@bjstijf-desktop:~$

sudo /etc/init.d/udev restart
bjstijf@bjstijf-desktop:~$ sudo /etc/init.d/udev restart

* Loading additional hardware drivers... [ OK ]

bjstijf@bjstijf-desktop:~$


Ik heb ook de kleuren aangegeven die de terminal aangeeft.
Sane geeft nog steeds aan, “ Geen apparaten aanwezig “

Groet,

de Ouwe.
"Er is meer tussen Hemel en Aarde, dan waarvan wij in al onze wijsheid dromen." :roll: