Voor mensen die aan linux ubuntu willen beginnen.

Iedereen kan hier terecht met vragen over allerhande open source software die niet in de andere fora past.
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

common sense schreef: En routeplanner spreken ze daar zeker ook uit als rauteplanner? :lol:

We wonen hier toch in Europa? En het is wel zo handig dat je het verschil een beetje kent tussen British English en American English. Voorbeeldje: colour (Engelse spelling) en color (Amerikaanse spelling) Maar dit begint echt teveel off-topic te geraken :D
Nee het is dan weer wel routeplanner. Allemaal heel onlogisch.
Engels en Amerikaans zit verschil in, maar het is beide goed te begrijpen.
Maar zoals je al zegt kun je hier nog lang over doorpraten, en het wordt te veel off-topic.
common sense schreef: Oorspronkelijk wel. Maar nu zijn er veel meer Linux ontwikkelaars van over de hele wereld. En deze werken allemaal samen via het Internet. Om je een idee te geven, een paar kaartjes van waar de ontwikkelaars wonen:
een kaart van de Debian ontwikkelaars
een kaart van de Gentoo ontwikkelaars
Europa staat er nog helemaal niet zo slecht voor!
adri schreef: Maar dan nog handiger.
Punt is wel dat je voor al dat gecompileer (ja, alles) wel liefst en beetje vlotte pc nodig hebt.
In Slackware kringen wordt het automagisch installeren van dependencies trouwens bepaald niet toegejuicht. :wink:
Maar het zal ook wel vlot gaan werken, alles wordt precies gebouwd voor jouw systeem.
Maar wat is er mis met het automatisch installeren van dependencies? Ik vind het juist ideaal!
Met Fedora is het wel jammer dat de dependencies niet automatisch verwijderd worden met het verwijderen van een programma. Er staan nu dus redelijk wat onnodige dingen op mijn systeem.
Bij Ubuntu kun je de niet meer nodige dependencies wel automatisch laten verwijderen (sudo apt-get autoremove)
adri schreef: Werkt apt-get dan niet?
Het heeft natuurlijk beperkingen, want DSL gebruikt i.v.m. de grootte nog een 2.4* kernel, maar ik dacht dat je daar toch redelijk mee uit de voeten kon.
Je kunt het wel inschakelen, en ik heb het nog even snel geprobeerd, maar ideaal werkt het niet. Je moet geluk hebben, wil de geinstalleerde software opstarten.
Maar DSL is hier ook niet voor bedoeld, het is gewoon een smalle distro, die best wel gebruiksvriendelijk is, alleen moeilijk uit te breiden.
adri schreef: Ja, ik herinner me je gedoe met Zenwalk nog goed. :)
Maar dat lag toch echt aan onwillige (te oude?) hardware.
Ik weet zeker als je een pc hebt waar het wel goed op aanslaat, dat je Zenwalk toch echt wel behoorlijk gebruiksvriendelijk zult vinden.
Ik had hem toen in Virtualbox getest, een programma dat toch wel redelijk bekende hardware emuleert, maar goed daar hoef ik niet meer over te praten, gewoon een ervaring die wel leerzaam was, maar meer ook niet.
Ik heb zenwalk 5 gedownload en ook in Virtualbox geinstalleerd, alleen Lilo wilde niet werken dus ik kan hem nog niet opstarten. Dat was gisteravond om 1 uur. Toen ben ik maar naar bed gegaan, en ik ga er een andere keer nog goed naar kijken (het is bijna zeker een fout van mij)

Maar goed, we zijn wel heel off-topic aan het gaan in deze Ubuntu-tread
rener
Berichten: 89
Lid geworden op: 31 januari 2008, 20:12
    unknown unknown

Bericht door rener »

Koen_92 schreef: Ik heb zenwalk 5 gedownload en ook in Virtualbox geinstalleerd, alleen Lilo wilde niet werken dus ik kan hem nog niet opstarten. Dat was gisteravond om 1 uur. Toen ben ik maar naar bed gegaan, en ik ga er een andere keer nog goed naar kijken (het is bijna zeker een fout van mij)

Maar goed, we zijn wel heel off-topic aan het gaan in deze Ubuntu-tread
Met behulp van deze link is de installatie van Zenwalk 5.0 op VirtualBox bij mij in ieder geval succesvol verlopen. Lees ook even de comments - met name de tip om het ext3 filesystem te kiezen in plaats van het standaard geselecteerde xfs. Mogelijk is dat de oorzaak van het probleem dat je beschrijft. En anders ... horen we hopelijk nader in een meer toepasselijke thread :wink: .
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Maar wat is er mis met het automatisch installeren van dependencies? Ik vind het juist ideaal! [/quote]
Je geeft zelf al een goed voorbeeld:
Koen_92 schreef: Met Fedora is het wel jammer dat de dependencies niet automatisch verwijderd worden met het verwijderen van een programma. Er staan nu dus redelijk wat onnodige dingen op mijn systeem.
Wat ook een nadeel is, is dat als programma's maar op eigen houtje libraries gaan installeren die ze nodig hebben je vroeg of laat problemen krijgt (vergelijkbaar met het .dll-gekloot dat je op Windows kunt hebben).
Bijv. als je een pakket verwijdert en die verwijdert ook vrolijk zijn benodigde libs mee (terwijl die ook nodig waren voor andere software) of twee verschillende programma's hebben dezelfde library nodig, maar met verschillende versienummers...
Dat kan erg lastig zijn, zo heb ik gisteren op SW12.1 Xmoto geïnstalleerd, die als dependencie Ode heeft, maar je hebt Ode 0.7, 0.8 en 0.9. Het is vaak een beetje uitproberen en zoeken welke bij jou goed werkt en andere progjes niet in de weg zit. Daar ben je soms wel even zoet mee, maar de rpm dependencies-hell is ook niet alles. ;)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ja op Fedora heb ik ook al eens zulke problemen gehad met programma's. Uiteindelijk is het op de één of andere manier goed gekomen. Yum installeerde de verkeerde versie van een library mee.

Op Ubunu heb ik eigenlijk nog nooit problemen of iets mee gehad, en daar werden alleen de dependencies verwijderd als ze echt niet meer nodig waren.

Met Slackware moet je dat dus zelf uitzoeken, waarschijnlijk heb je dan een iets slankere computer.
Maar moet je niet heel veel -dev library's installeren?

rener:
http://www.mozbrowser.nl/forum/viewtopi ... start=2160
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef: Met Slackware moet je dat dus zelf uitzoeken, waarschijnlijk heb je dan een iets slankere computer.
Maar moet je niet heel veel -dev library's installeren?
Dat valt erg mee, Slackware heeft al erg veel libs standaard aan boord. ;)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ok, nog één vraagje:

Als je een geinstalleerd programma wilt verwijderen, hoe weet je dan welke dependencies je mee kan verwijderen?
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef:Ok, nog één vraagje:

Als je een geinstalleerd programma wilt verwijderen, hoe weet je dan welke dependencies je mee kan verwijderen?
Met ldd kom je een heel eind. ;)
De eerlijkheid gebiedt te zeggen dat ik nauwelijks software verwijder en dus ook geen libs. Bij degenen die ik verwijder, weet ik zo uit het hoofd wel of er veel dependencies waren of niet (als je zelf compileert weet je dat nog wel).
Bovendien bewaar ik de door mijzelf gemaakte Slackware-pakketjes, ik kan dat dus altijd snel nakijken (kun je aan de datum zien).

Grofweg gezegd: mensen die veel & vaak software installeren zullen niet gauw Slackware gebruiken. :)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Nou, ik heb Fedora er af gegooid en Ubuntu er weer opgezet.
Mijn ervaring: één grote ramp!
Het was zo goed als onwerkbaar.

Toen ik Ubuntu had geinstalleerd (met de alternate cd, de desktop moet eerst een liveomgeving laden waar ik te lui voor ben), kwam meteen na de eerste start al een probleem: Alles was groen geworden!
Ik ben wezen sleutelen met xorg.conf, en uiteindelijk leek het goed te gaan. Alleen had ik na het aanmelden geen Gnome voor me, maar een wit scherm. Aangezien ik verder nog niets had gedaan en genoeg tijd had, heb ik maar een herinstallatie gedaan.
Toen leek alles goed te gaan, maar dat was niet voor lang.

Eerst maar het goede nieuws: op Gusty is het me nooit de gelukt de Ati driver werkend te krijgen (één van de redenen waarom Gusty niet meer werkte)

Nu wel, dankzij:
http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide

Nou ja, ik zat juigend achter mijn pc, Ubuntu leek gewoon alles perfect te doen, maar toen kwamen er problemen.
Ik was net amsn aan het installeren (sudo apt-get install amsn), en toen liep alles vast, het scherm bevriesde gewoon, en ik kon mijn muis niet meer bewegen of niets.
De uitknop was de enige optie.

Op dat moment dacht ik dat het door de Ati-driver kwam (ik wist dat dat instabiel kon zijn).

Maar ik ben gewoon verder gegaan, en toen kwam ik er achter dat het hele package-management systeem door de vastloper gemold was. Een vreemde error.
Ik heb op het Ubuntu-forum een topic geopend (hier zijn volgens mij niet veel mensen die wat af weten van apt-get):
http://forum.ubuntu-nl.org/topic/27223

Nu is dat weer hersteld, al krijg ik iedere keer na de installatie van een programma de error die ik daar in het laatste bericht heb laten zien.

Toen leek alles weer normaal te werken, maar bevroor de pc weer (dit keer was ik alleen aan het surfen).

Na een herstart heb ik dmesg gedaan, waar deze error stond:
APIC error on CPU0: 40(40)
Daarvoor stond een nummer, dat iedere keer dat ik dmesg uitvoerde een paar duizend keer zo groot werd.
Hierdoor wist ik dus dat de Ati-driver niet de boosdoener was.

Ik ben wat gaan Googlen, waar ergens stond dat ik moest opstarten met de opties noapic en acpi=off. Toen ik dat gedaan had leek alles weer normaal te werken, alleen kan ik niet meer afsluiten, dan moet ik de pc met de knop uitzetten (hij gaat dus niet vanzelf uit).

Verder krijg ik amsn niet meer werkend (ook niet na een reinstall), dit geeft een error:

Code: Selecteer alles

koen@ubuntu:~$ amsn
/usr/bin/wish8.5: 1: Syntax error: Unterminated quoted string
koen@ubuntu:~$ 
Verder vind ik de snelheid nog wel mee vallen, het gaat allemaal best snel (natuurlijk niet zo snel als Zenwalk), maar niet zo traag als Gusty.
Dat kan natuurlijk ook komen omdat ik nu JFS als filesystem heb gebruikt, op advies op dit forum.
JFS kan volgens mij goed tegen crashes, want dat heeft deze pc nu al 2 keer op een dag meegemaakt.

En tja, wat moet ik hier nu mee doen? Ik zit dit nu redelijk ontevreden met Ubuntu te typen (wachtend op een nieuw probleem). Moet ik Hardy nu langer gaan gebruiken, en proberen de bestaande problemen op te lossen? Zal ik weer terug keren naar Gutsy, waar ik altijd tevreden over ben geweest? Zal ik nog een herinstallatie wagen? Zal ik hem er af gooien en me proberen te redden met Zenwalk, iets dat redelijk gaat lukken maar nooit helemaal door mijn beperkte ervaring met Linux. Of moet ik naar een hele andere distro kijken? Suse, Mandriva of PClinuxOS bijvoorbeeld?
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Heb je hier misschien iets aan: http://www.amsn-project.net/forums/view ... =tkcximage ?

Wat je met Hardy moet doen moet je natuurlijk zelf weten...
Ik ga daar geen advies over geven, want dat is uiteraard erg bevooroordeeld. ;)

Het is nu eenmaal een gegeven dat bepaalde distro's op sommige hardware gewoon niet lekker lopen. Je kunt dan een andere proberen.
Afbeelding
rener
Berichten: 89
Lid geworden op: 31 januari 2008, 20:12
    unknown unknown

Bericht door rener »

Om te beginnen zou ik de installatie-CD onder de loep nemen. Misschien moet je die eens testen met een checksum test. Het zou niet de eerste keer zijn dat dit de oorzaak is van het soort foutmeldingen dat je nu ervaart.

Als de CD wel correct is zou wat mij betreft het tweede onderwerp van onderzoek het filesystem zijn:
Koen_92 schreef: JFS kan volgens mij goed tegen crashes, want dat heeft deze pc nu al 2 keer op een dag meegemaakt.
Misschien moet je dit launchpad artikel eens lezen. Het is weliswaar gedateerd, en het is voor mij lastig in te schatten of alles wat daarin staat nog actueel is. Maar hoewel de combinatie van JFS en AIX zich in de loop der jaren stabiel heeft getoond hoeft dat natuurlijk niet noodzakelijk te gelden voor de combinatie van JFS-implementatie en OS die momenteel op je PC draait :).

Hoe graag ik rond Linux ook experimenteer met andere zaken, voor filesystems houd ik het voor Linux meestal standaard bij ext3 (en straks ext4). Dat wordt op uitgebreide schaal toegepast op allerlei Linux systemen, waardoor er zeer ruime ervaring mee is opgedaan tijdens alpha- en betatesten van zowat alle bestaande Linux-distributies, dus ook Ubuntu.

Het staat iedereen natuurlijk vrij om dingen uit te proberen, maar het Ubuntu brainstorm idee om JFS de default keuze voor Ubuntu te maken vond alvast weinig weerklank ...
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

De cd is in ieder geval goed, die controleer ik namelijk altijd na het branden.
Bovendien heb ik hem al 2 keer uitgeleend, en daar is het ook goed gegaan.

Op zich valt het allemaal wel mee, ik dacht niet echt goed na.
Ik heb nu een herinstallatie gedaan, en nu op ext3, om dat probleem uit te sluiten.
Alles werkt weer (ook het pakketbeheer, dat ging alleen stuk doordat de computer vastliep op het moment van programma installeren).

UIteindelijk was de Ati-driver wél de boosdoener van deze error:
APIC error on CPU0: 40(40)

Die kwam namelijk pas nadat ik de atidriver had ingeschakeld. Nu kan de computer dus op ieder moment gaan vastlopen.

Die error is op te lossen door de optie acpi=off mee te geven met het starten, maar dan kan ik de computer niet meer uitschakelen.

Er moet toch een andere oplossing zijn? Of moet ik de atidriver verwijderen?
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Je bent de eerste (en ook de laatste) niet die gedonder heeft met de Ati-3D-drivers. Deïnstalleren is de beste optie. Als je per se 3D-versnelling wilt raad ik je aan om een Nvidia kaart te kopen. :)
Afbeelding
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ik had ook een Nvidia-kaart. Alleen wilde ik wat nieuwere games spelen zonder de hele pc te upgraden. (ja ik game nog, vandaar dus Windows XP).

Aangezien Nvidia AGP-kaarten al een tijdje heeft afgeschaft, moest ik dus wel een Ati.
Ati-kaarten hebben wel een veel betere prijs-kwaliteitverhouding. Maar helaas dat het onder Linux dus niet fatsoenlijk aan de gang te krijgen is.

Maar het is net goed gedaan :D
Ik boot nu met deze opties:
noapic nolapic

Toen startte hij wel op, zonder errors en afsluiten lukte ook gewoon. Tot nu toe ben ik nog geen nadelen tegengekomen van die opties.

Maar als het instabiel blijft verwijder ik de ati-drivers als nog. Alleen jammer dat ik met de vesa-driver niet de maximale resolutie van mijn beeldscherm kan halen...
Gebruikersavatar
Koen_92
Berichten: 758
Lid geworden op: 17 oktober 2006, 19:28
Locatie: Betuwe
    unknown unknown

Bericht door Koen_92 »

Ati-driver werkt na een kernel update niet meer :evil:

Dat wordt denk ik verwijderen, ik zou nog een tread op het Ubuntu forum kunnen aanmaken, daar heb ik namelijk een aantal mensen met dezelfde kaart als ik gezien (stond in hun handtekening).

Ook zou ik nog even kunnen wachten:
http://core.tweakers.net/nieuws/53699/o ... arten.html

Goed nieuws dus!

Helaas heb ik een R600 kaart, dus ik moet nog even wachten maar er wordt dus al 'aardige progressie' geboekt.
Als die drivers er komen en ze fatsoenlijk en vooral stabiel gaan werken, is het driver gezeur met ati eindelijk afgelopen :)

Mijn broertjes Ati-kaart (al een oudere) deed het al wel out-of-the-box met de open-source driver, compiz stond meteen na installatie al standaard aan in Ubuntu.

Mijn oude Nvidia-kaart (ongeveer even oud als de Ati van mijn broertje), deed het niet vanzelf. Die had echt nog propetaire drivers nodig.

Of moet dit het toch gaan worden?:
http://core.tweakers.net/nieuws/53591/o ... efase.html
Gebruikersavatar
adri
Moderator
Berichten: 11541
Lid geworden op: 5 maart 2005, 14:00
Locatie: Diessen
    unknown unknown

Bericht door adri »

Koen_92 schreef:Ati-driver werkt na een kernel update niet meer :evil:
Even katten: ik begrijp ook werkelijk niet waarom Ubuntu iedere nieuwe kernel-uitgave ook gelijk in de automatische updates meeneemt.
Dat is (ik heb het zelf ook een paar keer meegemaakt op Ubuntu, maar dan met Nvidia-drivers) gewoon vragen om ellende. En uiteindelijk ook de reden voor mij om Ubuntu buiten te zetten.
Afbeelding