AZvtar upload werkt niet?

Hier vind je nieuws over updates met betrekking tot de website. Ook kun je hier suggesties plaatsen.
Gebruikersavatar
FFuser
Berichten: 328
Lid geworden op: 11 augustus 2004, 19:25
Locatie: Antwerpen belgium
    unknown unknown

AZvtar upload werkt niet?

Bericht door FFuser »

Code: Selecteer alles

Warning: move_uploaded_file(./images/avatars/1032576652411b78366c594.png): failed to open stream: Permission denied in /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/usercp_avatar.php on line 227

Warning: move_uploaded_file(): Unable to move '/tmp/php5WWojk' to './images/avatars/1032576652411b78366c594.png' in /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/usercp_avatar.php on line 227

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/page_header.php on line 476

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/page_header.php on line 478

Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/usercp_avatar.php:227) in /home/httpd/vhosts/mozbrowser.nl/httpdocs/forum/includes/page_header.php on line 479
MozBrowser Forum Index
Dit zijn de foutmeldingen die ik krjg als ik een avatar wil uploaden.
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Gebruikersavatar
sc00zy
Berichten: 1811
Lid geworden op: 22 juli 2004, 10:03
Locatie: Assen
    unknown unknown

Bericht door sc00zy »

Dit komt omdat de site + forum is verhuisd naar een nieuwe server.
De rechten op de map waarin de avatars/images staan zijn nog niet goed ingesteld.

Dus nirwana... ff chmodden 8)
Laatst gewijzigd door sc00zy op 12 augustus 2004, 21:30, 1 keer totaal gewijzigd.
Gebruikersavatar
FFuser
Berichten: 328
Lid geworden op: 11 augustus 2004, 19:25
Locatie: Antwerpen belgium
    unknown unknown

Bericht door FFuser »

dat was mijn idee direct dat het daarmee te maken had
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Ria
Berichten: 478
Lid geworden op: 11 juli 2004, 17:38
    unknown unknown

Bericht door Ria »

Ik vind dat servers altijd zo'n onaardige taal uitbraken waar een argeloze surfer niks mee kan.
Gebruikersavatar
nirwana
Beheerder
Berichten: 11505
Lid geworden op: 19 september 2003, 5:09
    unknown unknown

Bericht door nirwana »

Ria schreef:Ik vind dat servers altijd zo'n onaardige taal uitbraken waar een argeloze surfer niks mee kan.
Tja, er zit duidelijk een 'mismatch' tussen wat een webserver-script meldt en wat een gebruiker zou verwachten. Eigenlijk zou er nog een laag tussen moeten zitten: de laag die de foutmelding opvangt en naar de gebruiker vertaald. Maar zo worden web-applicaties nog niet altijd geprogrammeerd.

Men gaat er nog iets te eenvoudig vanuit dat iets gewoon goed is ingericht en dus werkt (en blijft werken). Pas als blijkt dat iets veelvuldig fout gaat dan is er ongetwijfeld wel iemand die daar iets beters van gaat maken.

Maar in elk geval bedankt voor deze melding. Ik heb het probleem opgelost door inderdaad de rechten op de map met avatars aan te passen. Vervolgens heb ik mijn eigen avatar opnieuw proberen te uploaden en daarbij kreeg ik geen foutmelding. Dan ga ik er van uit dat het nu weer werkt.
Met vriendelijke groet,

Martijn
[ Mede-oprichter + webmaster MozBrowser | beheerder Startpagina's over freeware, GIMP, Mozilla en OpenOffice.org / LibreOffice, Ubuntu
Gebruikersavatar
sc00zy
Berichten: 1811
Lid geworden op: 22 juli 2004, 10:03
Locatie: Assen
    unknown unknown

Bericht door sc00zy »

nirwana schreef:Dan ga ik er van uit dat het nu weer werkt.
Ja het werkt inderdaad weer...

Gebeurt mij ook regelmatig bij het online site zetten van een site.
Ik bouw de sites voornamelijk offline (lokaal) op eigen server en upload deze later naar de werkelijke server.
Meestal vergeet ik de mappen niet te chmodden maar soms ook wel...
Als ik dat wel vergeet kom ik daar snel genoeg achter, als er een paniekerige klant aan de telefoon hangt die beweert dat de website niet werkt...

Terwijl ze alleen geen plaatjes kunnen uploaden... de wereld vergaat dan bijna in hun ogen :twisted: